Jump to content
Sign in to follow this  
Bruceleeon

New Stuff

Recommended Posts

I finally spent some money on my system again.

I got the Apogee, the Water block for the GPU, and some ramsinks for my vid card. 10 feel of .5 inch ID tubing, some clamps and some elbows. I am moving everything out of my PCV-2000B and putting it all back into my PC75 very soon. All I have left to get is a Northbridge water block and I think I will start assembling.

I have to figure out a drainage system though. I have a couple of valves from the origional swiftech closed system, but they are 3/8 ID. Maybe I will get some connectors that transform the sizes. It really won't inhibit the flow because they are strictly going to be for drainage.

Share this post


Link to post
Share on other sites

Nice, keep us posted.

Share this post


Link to post
Share on other sites

including pictures!

Share this post


Link to post
Share on other sites

I just placed an order for more crap to put my water rig back together...

1 x Swiftech MCW30 Chipset Water-block (MCW30) = $29.95

1 x Swiftech STORM Extreme Performance Universal Water-block - Rev 2 (STORM) = $79.95

3 x Polypropylene "T" Fitting 1/2" (T-FITTING-1/2) = $5.97

1 x Black Floppy Drive (D359M3-BL) = $8.95

2 x Polypropylene "Y" Fitting 1/2" (Y-FITTING-1/2) = $3.98

1 x Lian Li Deluxe Computer Assembly Hardware Kit (LL-SCREWKIT) = $12.50

2 x Swiftech MCRES-MICRO™ Reservoir (MCRES-MICRO) = $39.98

1 x 1/2" to 3/8" UV Reactive Leakproof Reducer (REDUCER12-38) = $1.50

1 x Swiftech MCP655™ 12 VDC Pump (MCP655) = $79.95

2 x Danger Den Fillport (FILLPORT) = $23.98

Fillport Color Clear Anodized

Fitting Size 1/2" for 1/2" I.D. Tubing

1 x RadGrillz™ Stripes 2x120 Aluminum Black ACR-RG35289 (ACR-RG35289) = $18.95

1 x Scythe "KAMA BAY" 120mm Fan for 5.25" System Cooling - Silver (SCKB-1000SL) = $19.95

Share this post


Link to post
Share on other sites

Damn, hit the lottery or what?

Share this post


Link to post
Share on other sites

I haven't updated this topic in a while...

I had the rig completely setup, but didn't find a tiny leak in my res. Since that time I have rebuilt the water setup about 3 times and have poored water on my components a bunch of times. This time, I am going to have to wait a couple of days before I power up because i had a decent size spill draining the system out.

I am going to try the Fluid XP coolant and see how it works. If it doesn't do well, I will have poored water on my components 2 of those times for nothing. I am anxious to see if it will live up to its claims about being able to be poored on a working system and have no effect on it.

I will test this out on an older pII setup!

Share this post


Link to post
Share on other sites

I have a small leak somewhere and I can't find it. My fluid levels are steadily dropping at a slow rate, but I can't find a leak anywhere. I am going to top it off and let it run for a few more days to see if it may just be some air that was released. I am skepticle that this is the case though because small air bubbles will not cause your res to lose almost .25 inches in fluids!

Share this post


Link to post
Share on other sites

Wap it in colored paper and watch it.

Share this post


Link to post
Share on other sites

I still have not found my leak... I don't know what is going on. I am hoping that it is just air being released from the rad or something.

Share this post


Link to post
Share on other sites

I'm telling you. Dry the outside of the radiator off completely, wrap it in colored paper and see if it leaks.

Share this post


Link to post
Share on other sites

I think I found the source of the dropping fluid levels...

I have always noticed a large congregation of air around it... i shook it around a bit and a TON of air was released!

Hopefully that will stop the fluid level drops

post-2-1150213709_thumb.png

Share this post


Link to post
Share on other sites

Love the reservoir window.

Share this post


Link to post
Share on other sites

Love the reservoir window.

So do I. :D

Share this post


Link to post
Share on other sites

I miss my res... I wanted to go back to the simple front though. I still have to mask my drives so they are invisible. Then all you will see is my two Rhostats and my floppy drive. YES I HAVE A FLOPPY DRIVE!

Share this post


Link to post
Share on other sites

Hey, so do I.

Share this post


Link to post
Share on other sites

It is hard to believe, but my floppy drive comes in SO HANDY! there are times when I can't live without it. i will go for months on end without using it... then, one day. I NEED IT!

Share this post


Link to post
Share on other sites

i like the mod!

if you haven't put in a N.B. water block i would suggest looking at the DD ones....

just installed one in my rig and it looks sweet

sorry... just browsed through your pics and saw you had one installed...

Edited by dougekewl

Share this post


Link to post
Share on other sites

I think at most times, NB watercooling is a waste of money. This is the first rig I have water cooled the NB and I don't notice much difference in temps. maybe 3C. The only reason I actually went ahead and did it this time around is because the fan on the sink that came with the mobo was failing.

Share this post


Link to post
Share on other sites

sweet rig! That is the next giveaway item right? :P

Share this post


Link to post
Share on other sites

If anyone ever noticed, my rig is in my sig. It is the computer in the picture I created as a site logo for COD

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×