Jump to content

Linksys Router May be slowing you down


Digital_Terror
 Share

Recommended Posts

If your computer is on a network via a Linksys router, you may want to check these settings. Every ISP is different. You need to set your router MTU data packet size to match what your ISP is dishing out.

I recently had some problems with a linksys 4 port router/switch. When I would download files, it would download like ~400kb and stop. No errors just stop and wait for more data. I would wait like 15 ~ 20 min..still no data.

When I had the same problem on a different computer on the same network, I realized it was the router.

After talking to Linksys Tec support, I was told that you have to optimize your connection by finding out what you ISP MTU setting is. (Most ISP will not list this value)

Go to command prompt and ping a web site, but use the following parameters.

ping www.yahoo.com -F -L 2100

You should get some kind of error that’s says DF needs to be set.

This means your number is two high.

keep repeating the ping and lowering the end number until you get some results. Pin Point that number. (My DSL was 1452) Now add 28 (Bits IP takes up or something like that). So my final MTU number dished out by my ISP is 1452+28=1480

Take this number and in Linksys under Advanced->Filters, there should be a MTU setting at the bottom of the page. Change it to your new number.

Check it out and see if it helps your downloads.

DT

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...